Mailchimp: Probleme mit der Formatierung in Firefox

MailChimp ist ein weitverbreitetes und sehr gut zu bedienendes Newsletter Tool, mit dem wir immer sehr gute Erfahrungen gemacht haben.
Umso erstaunter waren wir, als wir für einen Kunden einen Newsletter in MailChimp aufsetzten, welcher aber nach dem Versand durch unseren Kunden immer wieder massive Formatierungsprobleme aufwies.

Jeder unserer Testversände funktionierte einwandfrei, und auch alle Previews in MailChimp selbst zeigten keinen Fehler an. Doch sobald der Kunde selbst Hand daran anlegte, waren die Probleme wieder da. Wir haben einige Zeit investiert, um den Fehler zu finden, haben Code verglichen, sogar unsere Entwickler darauf angesetzt, um Diskrepanzen im Code zwischen unserem Testversand und dem offiziellen Versand durch den Kunden zu finden – ohne Ergebnis.

Als wir den Kunden zu uns ins Büro baten, um gemeinsam den nächsten Newsletter aufzusetzen (da es bei uns ja immer geklappt hatte), stellten wir folgendes fest:
Sobald ein Content Block im Design-Schritt der Erstellung (welcher im Testversand einwandfrei funktionierte) von unserem Kunden an seinem Laptop bearbeitet wurde, war die Formatierung dieses Blocks im nächsten Testversand wieder zerschossen, obwohl sich nach wie vor im HTML-Code in MailChimp keine Unterschiede feststellen liessen. Wir waren perplex … Bis die entscheidende Erleuchtung kam: Wir verwenden im Büro den Chrome Browser von Google, während unser Kunde den Newsletter mit Mozillas Firefox bearbeitete.
Nachdem Chrome auf dem Kunden-Laptop installiert war, kam die Bestätigung – nun konnte der Kunde nach Herzenslust den Newsletter bearbeiten, und die Formatierung blieb einwandfrei erhalten.

Es scheint also einen sehr kuriosen Bug in MailChimp zu geben, der sich anhand des NL-Codes nicht nachvollziehen lässt, der aber dennoch zu gravierenden Schwierigkeiten bei der Bearbeitung führen kann.

Da MailChimp in der kostenlosen Version (welche unser Kunde verwendet) keinen Support bietet, konnten wir den Support hierzu auch nicht kontaktieren. Wir haben eine Meldung zum Bug über das MailChimp Application Feedback eingereicht, haben aber bisher keine Rückmeldung zum Thema erhalten.

Falls Sie also auf ähnlich unerklärliche Probleme beim NL-Versand via MailChimp treffen: versuchen Sie es doch mal mit einem anderen Browser!

Haben Sie schon ähnliche Erfahrungen gemacht? Wir freuen uns immer über Feedback in den Kommentaren oder auch über eine E-Mail an info@k-webs.ch.

Schreiben Sie einen Kommentar

Ihre E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.